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Disclaimer
THIS SOFTWARE AND MANUAL ARE SOLD AS IS AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OF MERCHANT ABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED. BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE ENVIRONMENTS INTO 
WHICH THIS PROGRAM MAY BE PUT,    NO WARRANTY OF FITNESS    FOR A PARTICULAR 
PURPOSE IS OFFERED.      ANY PROGRAM SHOULD BE THOROUGHLY TESTED    WITH NON-
CRITICAL DATA    BEFORE RELYING ON IT.      THE USER MUST ASSUME    THE ENTIRE RISK OF 
USING    THE PROGRAM.      ANY LIABILITY    OF THE SELLER WILL BE LIMITED TO PRODUCT 
REPLACEMENT OR REFUND OF PURCHASE PRICE.



What is It?
Z & Z Puzzle is a product of Z & Z Software, a one person business named after my two children, 
Zachary and Zoë.    It is intended for used by children ages two and up.    For the smaller children it is 
recommended that you stick to the jigsaw puzzle.    For mathematically inclined children ages six and 
above, try the slider puzzle.    A slider puzzle with a large number of pieces can be very difficult even for 
an adult.    Therefore, be aware that the slider puzzle may be frustrating to small children. 

As a professional computer programmer and a devoted parent I can't help but look at a children's game 
without thinking about how I can make it better on a computer.    It can be more fun, more educational, 
and less frustrating.    

It started out as a slider puzzle that took advantage of a lot of the software written for its sister product, Z 
& Z Color (a color by number program available separately or together with Z & Z Puzzle - see 
registration).    It was expanded to include a jigsaw puzzle when I found that while some children loved it, 
others had difficulty figuring out how to solve the puzzle and became frustrated.    I hope you and your 
children enjoy it as much as my kids do.    

See the information on How to Solve a Slider Puzzle and How to Solve a Jigsaw Puzzle for the different 
ways to use this program.    The primary educational value of this game is in teaching puzzle (problem) 
solving skills.        



Registration
 The author of this program is a member of the Association of Shareware Professionals (ASP ).

Z & Z Puzzle is a shareware product.    As such, it is provided to you at little or no initial expense for a trial
period of thirty days.    After the thirty day period if you find that you do not wish to purchase the program 
simply delete it from your hard disk and/or floppies.    If you like the program, thank me by paying me $15 
plus postage and handling.    It is not free.    A great deal of effort went into the creation of this program.    
If you hope to see more programs like it you must support the shareware concept by sending in your 
registration.
Registration entitles you to the following:

The registered version, which includes a total of    THIRTY drawings as well as the ability to import 
bitmap (BMP) files so that drawings from other programs can be used as puzzles. 

Three months of support via telephone and the CompuServe computer service.    My CompuServe ID 
is 76021,2256.    I can be reached through the Internet at 76021,2256@compuserve.com.    My phone 
number is (410) 561-3891 (Please call in the evening, Eastern Standard Time).

Click on the game title below for more information on other fine Z & Z Software products.

Z & Z Color Game

Pennington Bonus Pack

FREE BONUS GAME 

CLICK HERE FOR PRICE LIST AND ORDERING INFORMATION 

You may copy this program and share it with others but you may not sell the software.    For more 
information refer to the topic on distribution.    



Z & Z Color
Z & Z Color is a Windows Color-by-Number game that is similar in style, interface, and quality to Z & Z 
Puzzle.    It teaches    colors, numbers, letters, shapes, and memory skills.    You may color on one of the 
included pictures or create your own.    As it is created for young children and it is designed to amuse and 
reward, a prize is awarded upon successful completion of each drawing.    Recommended for ages 3 and 
above.    Windows compatible sound board is recommended but not required

CLICK HERE FOR PRICE LIST AND ORDERING INFORMATION 



Pennington Bonus Pack
The    Pennington Bonus Pack is a separate floppy disk containing an additional FIFTY FOUR high 
quality drawings supplied by artist and Z & Z Software user Ross Pennington.    The Pennington Bonus 
Pack may be purchased at the time of your initial registration for $5 or separately at a later date for $8 ($5
plus $3 postage and handling).

CLICK HERE FOR PRICE LIST AND ORDERING INFORMATION 



Free Bonus Game
The free bonus game, Z & Z Recall, is available only with the purchase of the Z & Z Games package.    It 
is a memory game where a variety of items is displayed on the screen.    Take a real good look and then 
press the GO button.    Can you guess which item was removed?!    If you and/or your children love the 
other Z & Z Software games, they're sure to be crazy about this one too.    Loaded with options for 
beginners to experts, it will entertain you (while improving memory skills) for hours and hours.

CLICK HERE FOR PRICE LIST AND ORDERING INFORMATION 



Price List and Ordering Information
Price List (all amounts in US Dollars)
Z & Z Puzzle Game $15 _____
Z & Z Color Game $15 _____
Pennington Bonus Pack $5 _____
Z & Z Games Package (all of the above + free bonus game!) $30 _____
Upgrade to Z & Z Games package (registered Z & Z Software users) $15 _____

Postage and Handling (in US and Canada) $3 _____
International Postage and Handling $5 _____
TOTAL _____

Preferred method of payment is to mail your check to:

Jason Balmuth
Z & Z Software
1511 Norman Avenue
Lutherville, MD 21093
USA

Feel free to print this topic and complete your address below:

Name :
Address :
City :
State :
Country :
ZIP :

Note that registration can also be done on-line via CompuServe or by using your CREDIT CARD.    

Please send me any suggestions you might have for improvements and new features.    If I use your 
suggestion I'll send you a copy of the next version for free!



Compuserve Registration
Z & Z Puzzle may be registered in CompuServe's Shareware Registration Forum (GO SWREG).    The 
registration ID is ?????.

The registration ID for Z & Z Color    is 1406.

The registration ID for the Z & Z Games package, including the FREE bonus game , is ?????.



Credit Card Registration
You can order with MasterCard, Visa, American Express, or Discover from Public (software) Library by 
calling 800-2424-PsL or 713-524-6394, by sending a FAX to 713-524-6398, by CompuServe Email to 
71355,470, or by Internet Email to 71355,470@compuserve.com. You can also mail credit card orders to 

PsL
P.O. Box 35705
Houston, TX 77235-5705.

Ask for Z & Z Puzzle, product number 14173.

The product number for Z & Z Color    is 11741.

The product number for the full Z & Z Games package, including the FREE bonus game , is 14174.

NOTE THAT THE ABOVE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY.

THE AUTHOR OF THIS PROGRAM CANNOT BE REACHED AT THESE NUMBERS.

Any questions about the status of the shipment of the order, refunds, registration options, product details, 
technical support, volume discounts, dealer pricing, site licenses, non-credit card orders, etc., must be 
directed to Z & Z Software (see registration).

To insure that you get the latest version, PsL will notify Z & Z Software the day of your order and we will 
ship the product directly to you.



Distribution of Z & Z Puzzle
You may copy this program and share it with others but you may not sell the software.    Anyone wishing 
to charge people a fee for giving them a copy of Z & Z Puzzle must have the written authorization of the 
author, without which, the distributor is guilty of copyright violation.    To receive such authorization print 
and sign the agreement listed below and send it to me at the address listed above.    Include $3 to cover 
postage and handling for the latest version of Z & Z Puzzle.    For distributors already recognized by the 
Association of Shareware Professionals this authorization is not necessary.    

TERMS OF DISTRIBUTION OF Z & Z Puzzle

1. The fee charged may not exceed $10, including postage, mailer and any other charges.

2. Your libraries catalog or listing must state that this program is not free, but is copyrighted software that 
is provided to allow the user to evaluate it before paying.

3. The offering and sale of Z & Z Puzzle will be stopped at any time the author so requests.

4. Copies must be made from the disk sent to you with this agreement.    This is required for control 
purposes.    

5.    Problems or complaints about the program will be reported to the author for investigation.    In return 
for a license to charge a fee for the distribution of the program Z & Z Puzzle, I agree to comply with the 
above terms of distribution.

Signed, _____________________________________      ______________
                                                          your signature                                                                                  date



If you have problems...
Z & Z Puzzle underwent quite a bit of testing by myself, my kids, and other Beta testers before it reached 
your hands.    However, I would not want to bet my life that there are no bugs remaining in the program.    
If you have a registered copy of the program (see Registration for more information) and you are the first 
one to inform me of a problem, I'll fix it and send you a free copy of the next version as soon as possible.   
If you have an unregistered copy I'm still interested in hearing about the problem but you must register in 
order to get the free copy.

Send as much information as you can gather on any other problems to 

Jason Balmuth
Z & Z Software
1511 Norman Avenue
Lutherville, MD 21093

CompuServe: 76021,2256
Internet: 76021,2256@compuserve.com
Phone: (410) 561-3891 (preferably evenings, Eastern Standard Time)



Shareware and the ASP
This program is produced by a member of the Association of Shareware Professionals (ASP).      The ASP
wants to make sure that the shareware principle works for you. If you are unable to resolve a shareware-
related problem with an ASP member by contacting the member directly, ASP may be able to help. The 
ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does not provide 
technical support for members' products.    Please write to the ASP Ombudsman at 545 Grover Road, 
Muskegon, MI 49442 or send a CompuServe message via CompuServe Mail to ASP Ombudsman 
70007,3536.

Shareware distribution gives users a chance to try software before buying it. If you try a Shareware 
program and continue using it, you are expected to register. Individual programs differ on details -- some 
request registration while others require it, some specify a maximum trial period.    With registration, you 
get anything from the simple right to continue using the software to an updated program with printed 
manual.    Copyright laws apply to both Shareware and commercial software, and the copyright holder 
retains all rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is in the method of distribution. The author 
specifically grants the right to copy and distribute the software, either to all and sundry or to a specific 
group. For example, some authors require written permission before a commercial disk vendor may copy 
their Shareware.    Shareware is a distribution method, not a type of software. You should find software 
that suits your needs and pocketbook, whether it's commercial or Shareware. The Shareware system 
makes fitting your needs easier, because you can try before you buy.    And because the overhead is low, 
prices are low also. Shareware has the ultimate money-back guarantee -- if you don't use the product, 
you don't pay for it.



Sound Support
Z & Z Puzzle contains sound effects which are compatible with any sound board which works under 
Windows.    As anyone with kids will attest, adding audio to a children's game doubles the fun (and 
doubles the educational value, too!).    

Note that you can create your own audio files for use with Z & Z Puzzle.    Simply use whatever WAV file 
recording tools came with your sound board to record your own sounds and save the file under one of the
names listed below, in the same directory as the Z & Z Puzzle program.    The audio files used by Z & Z 
Puzzle for all drawings are:

ZZPWELC.WAV Introduction, plays on entry to program

BYE.WAV Good-bye, plays on exit from program

WIN.WAV Default congratulations for completing puzzle correctly

MATCH.WAV Piece was moved to correct location

MOVEOKL.WAV
MOVEOKR.WAV
MOVEOKD.WAV
MOVEOKU.WAV Piece was moved to incorrect location

MOVEBAD.WAV Illegal move.

MOVENOP.WAV Not on a piece.

UNDO.WAVUndo menu item was selected or button was pressed. 



How to Solve a Slider Puzzle
When Z & Z Puzzle first starts up the Next Drawing command (from the File menu) is executed to 
randomly select a puzzle from the current directory.    To select another drawing use the Next Drawing, 
Open, or Select Drawing commands from the File menu.    

Now select the desired options via menu commands or the buttons along the left hand side of the window.
Choose the slider type puzzle, the number of pieces in the puzzle, and when coloring of the puzzle (ZZC 
files only - see the Open command on the File menu) should take place.    See the Options menu topic for 
more information on the various options 

To move a puzzle piece, press and release either mouse button on the piece that you wish to move.    
Alternatively you may press the mouse button on the piece to move and then release it over the blank 
piece (shown in dark gray).    Note that only pieces next to the blank piece may be moved.    If the piece is 
moved to its proper location and the Color when Correct" option is selected (ZZC files only) the piece will 
be colored in automatically to provide visual a clue towards the solution of the puzzle (extremely useful for
younger children and in puzzles with a large number of pieces).    Audio clues are also provided (see 
digital audio.    When the puzzle is completed correctly you will be rewarded with a prize.

Note that the keyboard may be used in place of the mouse.

If you want to do the same puzzle again use the Clear command on the Edit menu to start over again.    If 
you want to try another drawing use the Next Drawing, Select Drawing..., or Open... command from the 
File menu.



How to Solve a Jigsaw Puzzle
When Z & Z Puzzle first starts up the Next Drawing command (from the File menu) is executed to 
randomly select a puzzle from the current directory.    To select another drawing use the Next Drawing, 
Open, or Select Drawing commands from the File menu.    

Now select the desired options via menu commands or the buttons along the left hand side of the window.
Choose the jigsaw type puzzle, the number of pieces in the puzzle, and when coloring of the puzzle (ZZC 
files only - see the Open command on the File menu) should take place..    See the Options menu topic for
more information on the various options 

To move a puzzle piece, press and hold either mouse button when the cursor is over the piece that you 
wish to move.    Now move the mouse such that the cursor is positioned over the location that you wish to 
move the piece to and release the mouse button.    The piece moved is switched with the puzzle piece at 
the destination.    If either piece was moved to its proper location and the Color when Correct" option is 
selected (ZZC files only) the piece will be colored in automatically to provide visual a clue towards the 
solution of the puzzle (extremely useful for younger children and in puzzles with a large number of 
pieces).    Audio clues are also provided (see digital audio.    When the puzzle is completed correctly you 
will be rewarded with a prize.

Note that the keyboard may be used in place of the mouse.

If you want to do the same puzzle again use the Clear command on the Edit menu to start over again.    If 
you want to try another drawing use the Next Drawing, Select Drawing..., or Open... command from the 
File menu.



Keyboard Interface
Z & Z Puzzle provides a fully functional keyboard interface that may be used instead of the mouse. 

Use the arrow keys (up, down, left, and right) to position the cursor over the piece you wish to move.    For
the Slider puzzle, press and release the space bar to move the piece.    For the Jigsaw puzzle, press and 
hold the space bar while using the arrow keys to move the cursor to the destination.    Release the space 
bar to swap the pieces.



File Menu

The Next Drawing command (same as the  button) is used to randomly select a new puzzle drawing 
from one of the files in the current directory.    If there are any .ZZC files (Z & Z Color format) in the current
directory it will choose one of those.    If not and there are .BMP files (Windows bitmap format) it will select
a file of that type (registered version only!).    
The Open command is used to select a new puzzle drawing.    A    dialog box appears to allow for 
selection of either a Z & Z Color file or a bitmap file to use as a puzzle.    Note that use of bitmap files is 
allowed in the registered version only and the options to "Color when Correct" and "Color when Done" are
disabled (see Options menu) .

The Select Drawing command (same as the  button) brings up a dialog box to provide an interactive 
method for selecting a new puzzle drawing.    A thumbnail sketch of each puzzle drawing is provided, six 
drawings to a page.    To select a puzzle, double click with the left mouse button or single click and then 
press the OK button.    Use the Prev and Next buttons to see additional "pages" of drawings to select 
from.    Alternatively, the keyboard can be used for selection.    The arrow keys move among the drawings 
and the Enter key can be used to complete your selection.    Page Up and Page Down are identical to 
Prev and Next, respectively.

Exit closes the Z & Z Puzzle Window.    Do not use this command until you are finished playing with this 
application.



Edit Menu

The Undo command (same as the  button) restores the puzzle to its state prior to the last move.    If 
you are unhappy with your last move (or series of moves) use this command to backtrack the desired 
number of moves (up to 100).

The Clear command (same as the  button) is used to re-scramble a puzzle.    Use this command to 
try the same puzzle again.
Show Completed Picture solves the current puzzle for you; shows you what the completed puzzle 
drawing    looks like.    



Options Menu

Z & Z Puzzle is really two games combined into one: a Jigsaw Puzzle    (  button is down, check mark
appears next to menu item) and a Slider Puzzle (

 button is down, check mark appears next to menu item).
The Number of Pieces... command brings up a dialog box to enter the desired number of puzzle pieces 
(as small as 2 by 2 or as large as 10 by 10).    Several buttons are provided as shortcuts for changing 

puzzle size; 9 pieces (  button is down), 16 pieces (

 button is down), and 25 pieces (

 button is down).
Digital Sounds is a toggle switch.    When checked or enabled, as it is by default, Z & Z Puzzle will 
attempt to respond to the user with pre-recorded digital sounds in the form of windows WAV files.    If the 
switch is unchecked or disabled, no sound will be emitted.    See Sound Support for more information on 
sound in Z & Z Puzzle.

The option to Color when Correct (  button is down, check mark appears next to menu item) results 
in the pieces being colored only when they are in the correct location.    The option to Color when Done (

 button is down, check mark appears next to menu item) results in the pieces being colored only 
when the entire puzzle is solved correctly.    Finally, the Color at Start (

 button is down, check mark appears next to menu item) option results in the pieces always being 
colored.    Note that only the last option (Color at Start) is available when using Windows BMP files as 
puzzle drawings.



Help Menu
Selecting Contents from the Help menu brings you to the title/table of contents page in the Z & Z Puzzle 
online help system.

Using Help displays general information on how to use the Windows Help system.

About Z & Z Puzzle... brings up a brief dialog box tells you the version number of the program, its 
authors, and your registration status, or lack thereof.

 




